Home Forums Usage How can I run SCH schematic simulation from Octave?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1008
    rosti75
    Participant

    Hello,

    In my project I have to run the SCH simulations and Octave simulations one after another. Is there a way to run SCH simulation from Octave? Is there a command to do that? Something like this:

    command_to_run(SCH schematic1)

    Octave_code1

    command_to_run(SCH schematic2)

    Octave_code2

     

    #1011
    zhu
    Participant

    To my knowledge there is no such command (yet) in QucsStudio. However there is a possibility to run SCH-s from, and return data to Octave.

    %outfile=fullfile(‘”C:\Documents and Settings\zhu\qucs3\model_prj”‘,’model.dat’);
    %outfile=fullfile(‘C:\Documents and Settings\zhu\qucs3\model_prj’,’model.dat’);
    outfile=’model.dat’;

    Neither of the commented lines work for resolving the problem of spaces in paths. Interestingly,

    infile=fullfile(‘”C:\Documents and Settings\zhu\qucs3″‘,’netlist.txt’);

    works for the input file.

    There must exist a solution I do not know of.

    #2997
    Tiberius
    Participant

    I was poking through the forum topics to see what people are doing that I might be able to learn from and came across this.

    Could you explain what your fgsolve.txt file is doing? (Alternatively, could you point me in the right direction for documentation?) I’m just curious to learn more things I can do.

    #2998
    zhu
    Participant

    fgsolve.m (*.txt renamed) is an example Octave routine for running a Qucsstudio simulation and importing the results in the Octave domain. The netlist.txt to be invoked must be prepared by the User. The simplest way is to draw the scematic and running it. netlist.txt is automatically placed in the user directory. Next, qucssim.exe is invoked in DOS with the specified input and output files. The results are made available for Octave by the standard function loadQucsVariable.m.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.